Thread (389 messages) flat view 389 messages, 13 authors, 2021-08-21

Re: [PATCH v14 067/138] mm/writeback: Add folio_start_writeback()

From: David Howells <dhowells@redhat.com>
Date: 2021-08-10 21:34:43
Also in: linux-fsdevel, lkml

Matthew Wilcox (Oracle) [off-list ref] wrote:
Rename set_page_writeback() to folio_start_writeback() to match
folio_end_writeback().  Do not bother with wrappers that return void;
callers are perfectly capable of ignoring return values.

Add wrappers for set_page_writeback(), set_page_writeback_keepwrite() and
test_set_page_writeback() for compatibililty with existing filesystems.
The main advantage of this patch is getting the statistics right,
although it does eliminate a couple of calls to compound_head().

Signed-off-by: Matthew Wilcox (Oracle) <willy@infradead.org>
Reviewed-by: Christoph Hellwig <hch@lst.de>
Reviewed-by: David Howells <dhowells@redhat.com>

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help