On Wed, Jun 16, 2021 at 11:03:23AM +0100, David Howells wrote:
Matthew Wilcox (Oracle) [off-list ref] wrote:
quoted
folio_index() is the equivalent of page_index() for folios.
folio_file_page() is the equivalent of find_subpage().
folio_contains() is the equivalent of thp_contains().
No changes to generated code.
Signed-off-by: Matthew Wilcox (Oracle) <willy@infradead.org>
Reviewed-by: Christoph Hellwig <hch@lst.de>
Acked-by: Jeff Layton <jlayton@kernel.org>
Acked-by: Kirill A. Shutemov <redacted>
Acked-by: Vlastimil Babka <redacted>
Reviewed-by: William Kucharski <redacted>
folio_subpage() might be a better name than folio_file_page().
I want it to be clear that you can't call this for folios which
aren't part of a file. For example, anonymous memory.