Re: [PATCH v4 00/25] Page folios
From: Christoph Hellwig <hch@infradead.org>
Date: 2021-03-15 19:10:49
Also in:
linux-fsdevel, lkml
On Mon, Mar 15, 2021 at 01:38:04PM +0100, Michal Hocko wrote:
I tend to agree here as well. The level compoud_head has spread out silently is just too large. There are people coming up with all sorts of optimizations to workaround that, and they are quite right that this is somehing worth doing, but last attempts I have seen were very focused on specific page flags handling which is imho worse wrt maintainability than a higher level and type safe abstraction. I find it quite nice that this doesn't really have to be a flag day conversion but it can be done incrementally. I didn't get review the series yet and I cannot really promise anything but from what I understand the conversion should be pretty straightforward, albeit noisy. One thing that was really strange to me when seeing the concept for the first time was the choice of naming (no I do not want to start any bikeshedding) because it hasn't really resonated with the udnerlying concept. Maybe just me as a non native speaker... page_head would have been so much more straightforward but not something I really care about.
That pretty much summarizes my opinion as well. I'll need to find some time to review the series as well.