Thread (43 messages) 43 messages, 4 authors, 2017-06-19

Re: [Cluster-devel] [PATCH 00/35 v1] pagevec API cleanups

From: Jan Kara <jack@suse.cz>
Date: 2017-06-01 12:05:59
Also in: ceph-devel, linux-btrfs, linux-ext4, linux-f2fs-devel, linux-xfs

On Thu 01-06-17 04:36:04, Christoph Hellwig wrote:
On Thu, Jun 01, 2017 at 11:32:10AM +0200, Jan Kara wrote:
quoted
* Implement ranged variants for pagevec_lookup and find_get_ functions. Lot
  of callers actually want a ranged lookup and we unnecessarily opencode this
  in lot of them.
How does this compare to Kents page cache iterators:

http://www.spinics.net/lists/linux-mm/msg104737.html
Interesting. I didn't know about that work. I guess the tradeoff is pretty
obvious - my patches are more conservative (changing less) and as a result
the API is not as neat as Kent's one. That being said I was also thinking
about something similar to what Kent did but what I didn't like about such
iterator is that you still need to specially handle the cases where you
break out of the loop (you need to do that with pagevecs too but there it
is kind of obvious from the API).

								Honza
-- 
Jan Kara [off-list ref]
SUSE Labs, CR

--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@kvack.org.  For more info on Linux MM,
see: http://www.linux-mm.org/ .
Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help