Thread (11 messages) 11 messages, 4 authors, 2015-09-23

Re: [PATCH 3/3] mm/compaction: add an is_via_compact_memory helper function

From: David Rientjes <rientjes@google.com>
Date: 2015-09-21 23:03:18
Also in: lkml

On Wed, 16 Sep 2015, Yaowei Bai wrote:
Introduce is_via_compact_memory helper function indicating compacting
via /proc/sys/vm/compact_memory to improve readability.

To catch this situation in __compaction_suitable, use order as parameter
directly instead of using struct compact_control.

This patch has no functional changes.

Signed-off-by: Yaowei Bai <redacted>
Acked-by: David Rientjes <rientjes@google.com>

Thanks for doing these cleanups!

--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@kvack.org.  For more info on Linux MM,
see: http://www.linux-mm.org/ .
Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help