Thread (29 messages) 29 messages, 3 authors, 2013-08-08
STALE4734d REVIEWED: 1 (0M)
Revisions (4)
  1. v1 [diff vs current]
  2. v2 [diff vs current]
  3. v2 [diff vs current]
  4. v3 current

[PATCH v3 12/25] x86, acpi: Rename check_multiple_madt() and make it global.

From: Tang Chen <hidden>
Date: 2013-08-07 11:13:41
Also in: linux-acpi, lkml
Subsystem: acpi, the rest · Maintainers: "Rafael J. Wysocki", Linus Torvalds

Since we split acpi_table_init() into two steps, and want to do
the two steps separately, we need to do check_multiple_madt() after
acpi_table_init_override().

But we also have to keep acpi_table_init() as before because it
is also used in ia64, we have to do check_multiple_madt() directly
in acpi_boot_table_init() in x86.

This patch make check_multiple_madt() global, and rename it to
acpi_check_multiple_madt() because all interfaces provided by
drivers/acpi/tables.c begins with "acpi_".

Signed-off-by: Tang Chen <redacted>
Reviewed-by: Zhang Yanfei <redacted>
---
 drivers/acpi/tables.c |    4 ++--
 include/linux/acpi.h  |    1 +
 2 files changed, 3 insertions(+), 2 deletions(-)
diff --git a/drivers/acpi/tables.c b/drivers/acpi/tables.c
index 4913a85..45727b2 100644
--- a/drivers/acpi/tables.c
+++ b/drivers/acpi/tables.c
@@ -314,7 +314,7 @@ int __init acpi_table_parse(char *id, acpi_tbl_table_handler handler)
  * but some report two.  Provide a knob to use either.
  * (don't you wish instance 0 and 1 were not the same?)
  */
-static void __init check_multiple_madt(void)
+void __init acpi_check_multiple_madt(void)
 {
 	struct acpi_table_header *table = NULL;
 	acpi_size tbl_size;
@@ -369,7 +369,7 @@ int __init acpi_table_init(void)
 
 	acpi_table_init_override();
 
-	check_multiple_madt();
+	acpi_check_multiple_madt();
 
 	return 0;
 }
diff --git a/include/linux/acpi.h b/include/linux/acpi.h
index 9704179..44a3e5f 100644
--- a/include/linux/acpi.h
+++ b/include/linux/acpi.h
@@ -95,6 +95,7 @@ void acpi_boot_table_init (void);
 int acpi_mps_check (void);
 int acpi_numa_init (void);
 
+void acpi_check_multiple_madt(void);
 int acpi_table_init_firmware(void);
 void acpi_table_init_override(void);
 int acpi_table_init (void);
-- 
1.7.1

--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@kvack.org.  For more info on Linux MM,
see: http://www.linux-mm.org/ .
Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help