Re: CK1 [09/13] slab: rename nodelists to node
From: Christoph Lameter <hidden>
Date: 2012-09-28 14:45:59
On Fri, 28 Sep 2012, Glauber Costa wrote:
quoted
-extern struct kmem_cache *cs_cachep[PAGE_SHIFT + MAX_ORDER]; -extern struct kmem_cache *cs_dmacachep[PAGE_SHIFT + MAX_ORDER]; - void *kmem_cache_alloc(struct kmem_cache *, gfp_t); void *__kmalloc(size_t size, gfp_t flags);@@ -132,10 +129,10 @@ static __always_inline void *kmalloc(siz #ifdef CONFIG_ZONE_DMA if (flags & GFP_DMA) - cachep = cs_dmacachep[i]; + cachep = kmalloc_dma_caches[i]; elseYou had just changed this to those new names in patch 7. Why don't you change it directly to kmalloc_{,dma}_caches ?
Right. This is also not really related to what this patch ought to do. -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@kvack.org. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>