On Wed, Jun 27, 2012 at 4:01 PM, Peter Zijlstra [off-list ref] wrote:
How about something like this
Looks better.
I'd be even happier if you made the whole
"When there's less then two users.."
(There's a misspelling there, btw, I didn't notice until I
cut-and-pasted that) logic be a helper function, and have that helper
function be inside that same #ifdef CONFIG_STRICT_TLB_FILL block
together witht he tlb_table_flush_mmu() function.
IOW, something like
static int tlb_remove_table_quick( struct mmu_gather *tlb, void *table)
{
if (atomic_read(&tlb->mm->mm_users) < 2) {
__tlb_remove_table(table);
return 1;
}
return 0;
}
for the CONFIG_STRICT_TLB_FILL case, and then the default case just
does an unconditional "return 0".
So that the actual code can avoid having #ifdef's in the middle of a
function, and could just do
if (tlb_remove_table_quick(tlb, table))
return;
instead.
Maybe it's just me, but I detest seeing #ifdef's in the middle of
code. I'd much rather have the #ifdef's *outside* the code and have
these kinds of helper functions that sometimes end up becoming empty.
Linus
--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@kvack.org. For more info on Linux MM,
see: http://www.linux-mm.org/ .
Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>