Thread (4 messages) 4 messages, 4 authors, 2012-06-06

RE: [PATCH] powerpc: Fix assmption of end_of_DRAM() returns end address

flat view

From: Bhushan Bharat-R65777 <hidden>
Date: 2012-06-06 00:46:51
Also in: linuxppc-dev, lkml

-----Original Message-----
From: David Miller [mailto:davem@davemloft.net]
Sent: Wednesday, June 06, 2012 3:51 AM
To: benh@kernel.crashing.org
Cc: Bhushan Bharat-R65777; <redacted>; linux-
kernel@vger.kernel.org; galak@kernel.crashing.org; Bhushan Bharat-R65777
Subject: Re: [PATCH] powerpc: Fix assmption of end_of_DRAM() returns end address

From: Benjamin Herrenschmidt <benh@kernel.crashing.org>
Date: Wed, 06 Jun 2012 08:17:39 +1000
quoted
On Tue, 2012-06-05 at 19:25 +0530, Bharat Bhushan wrote:
quoted
memblock_end_of_DRAM() returns end_address + 1, not end address.
While some code assumes that it returns end address.
Shouldn't we instead fix it the other way around ? IE, make
memblock_end_of_DRAM() does what the name implies, which is to return
the last byte of DRAM, and fix the -other- callers not to make bad
assumptions ?
That was my impression too when I saw this patch.
Initially I also intended to do so. I initiated a email on linux-mm@  subject "memblock_end_of_DRAM()  return end address + 1" and the only response I received from Andrea was:

"
It's normal that "end" means "first byte offset out of the range". End = not ok.
end = start+size.
This is true for vm_end too. So it's better to keep it that way.
My suggestion is to just fix point 1 below and audit the rest :)
"

Thanks
-Bharat

--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@kvack.org.  For more info on Linux MM,
see: http://www.linux-mm.org/ .
Fight unfair telecom internet charges in Canada: sign http://stopthemeter.ca/
Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help