Re: [PATCH -mmotm] fault-injection: add ability to export fault_attr in arbitrary directory
From: Andrew Morton <akpm@linux-foundation.org>
Date: 2011-07-26 23:17:25
Also in:
lkml
On Wed, 27 Jul 2011 08:06:37 +0900 Akinobu Mita [off-list ref] wrote:
init_fault_attr_dentries() is used to export fault_attr via debugfs. But it can only export it in debugfs root directory. Per Forlin is working on mmc_fail_request which adds support to inject data errors after a completed host transfer in MMC subsystem. The fault_attr for mmc_fail_request should be defined per mmc host and export it in debugfs directory per mmc host like /sys/kernel/debug/mmc0/mmc_fail_request. init_fault_attr_dentries() doesn't help for mmc_fail_request. So this introduces debugfs_create_fault_attr() which is able to create a directory in the arbitrary directory and replace init_fault_attr_dentries().
The name is wrong. "debugfs_create_fault_attr" refers to some function
exported by the debugfs code. But this function is exported by the
fault injection code.
I edited the patch and renamed it to fault_create_debugfs_attr, which
may not make a ton of sense - please let me know if there's something
more appropriate.
I suggest that all symbols exported by this system should start with
"fault_". ("fault_injection_" would be more appropriate, but it's
rather lengthy). Please take a look through the code, see if there's
anything else we should clean up.
--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@kvack.org. For more info on Linux MM,
see: http://www.linux-mm.org/ .
Fight unfair telecom internet charges in Canada: sign http://stopthemeter.ca/
Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>