Re: [RFC][PATCH 1/2] rename alloc_pages_exact()
From: Andi Kleen <hidden>
Date: 2011-03-22 19:42:57
On Tue, Mar 22, 2011 at 12:15:02PM -0700, Dave Hansen wrote:
alloc_pages_exact() returns a virtual address. But, alloc_pages() returns a 'struct page *'. That makes for very confused kernel hackers. __get_free_pages(), on the other hand, returns virtual addresses. That makes alloc_pages_exact() a much closer match to __get_free_pages(), so rename it to get_free_pages_exact(). Note that alloc_pages_exact()'s partner, free_pages_exact() already matches free_pages(), so we do not have to touch the free side of things.
Yes, that was wrong from the start. Thanks for fixing. Acked-by: Andi Kleen <redacted> -Andi -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@kvack.org. For more info on Linux MM, see: http://www.linux-mm.org/ . Fight unfair telecom internet charges in Canada: sign http://stopthemeter.ca/ Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>