Re: [PATCHv2 00/24] Refactor sys_swapon
From: Cesar Eduardo Barros <hidden>
Date: 2011-03-04 22:54:26
Em 03-03-2011 13:15, Eric B Munson escreveu:
On Tue, 01 Mar 2011, Cesar Eduardo Barros wrote:quoted
This patch series refactors the sys_swapon function. sys_swapon is currently a very large function, with 313 lines (more than 12 25-line screens), which can make it a bit hard to read. This patch series reduces this size by half, by extracting large chunks of related code to new helper functions. One of these chunks of code was nearly identical to the part of sys_swapoff which is used in case of a failure return from try_to_unuse(), so this patch series also makes both share the same code. As a side effect of all this refactoring, the compiled code gets a bit smaller (from v1 of this patch series): text data bss dec hex filename 14012 944 276 15232 3b80 mm/swapfile.o.before 13941 944 276 15161 3b39 mm/swapfile.o.after The v1 of this patch series was lightly tested on a x86_64 VM.One more small suggestion, you should cc LKML on this series, as well as any of the other emails suggested by get_maintainer.pl.
Should I resend the whole patch series with the correct Cc:? -- Cesar Eduardo Barros cesarb@cesarb.net cesar.barros@gmail.com -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@kvack.org. For more info on Linux MM, see: http://www.linux-mm.org/ . Fight unfair telecom internet charges in Canada: sign http://stopthemeter.ca/ Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>