Re: [PATCH 6/8] Add __GFP_OTHER_NODE flag
From: David Rientjes <rientjes@google.com>
Date: 2011-02-22 22:09:06
Also in:
lkml
On Tue, 22 Feb 2011, Andi Kleen wrote:
quoted
This makes the accounting worse, NUMA_LOCAL is defined as "allocation from local node," meaning it's local to the allocating cpu, not local to the node being targeted.Local to the process really (and I defined it originally ...) That is what I'm implementing I don't think "local to some random kernel daemon which changes mappings on behalf of others" makes any sense as semantics.
You could make the same argument for anything using kmalloc_node() since preferred_zone may very well not be on the allocating cpu's node. So you either define NUMA_LOCAL to account for when a cpu allocates memory local to itself (as it's name implies) or you define it to account for when memory comes from the preferred_zone's node as determined by the zonelist. It's not useful to change it from the former to the latter since it's already the definition of NUMA_HIT. -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@kvack.org. For more info on Linux MM, see: http://www.linux-mm.org/ . Fight unfair telecom internet charges in Canada: sign http://stopthemeter.ca/ Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>