Re: [PATCH] mm/vmscan: rename zone_nr_pages() to zone_lru_nr_pages()
From: Vincent Li <hidden>
Date: 2009-08-21 15:49:01
On Thu, 20 Aug 2009, Andrew Morton wrote:
On Thu, 20 Aug 2009 11:42:54 -0700 Vincent Li [off-list ref] wrote:quoted
Name zone_nr_pages can be mis-read as zone's (total) number pages, but it actually returns zone's LRU list number pages.Fair enough.quoted
-static unsigned long zone_nr_pages(struct zone *zone, struct scan_control *sc, +static unsigned long zone_lru_nr_pages(struct zone *zone, struct scan_control *sc,Wouldn't zone_nr_lru_pages() be better?
I see name isolate_lru_page and the meaning of number of lru pages. your suggestion is better. should I resend the patch with your suggestion? I ask because I saw you already put the patch in the mmotm tree before you send this email out. Vincent Li Biomedical Research Center University of British Columbia -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@kvack.org. For more info on Linux MM, see: http://www.linux-mm.org/ . Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>