Re: [Lhms-devel] Re: [PATCH 1/9] add defrag flags
From: Paul Jackson <hidden>
Date: 2005-09-27 16:26:24
Also in:
lkml
Mel wrote:
quoted
If you have good reason to keep __GFP_USER meanin either user or buffer, then perhaps the name __GFP_USER is misleading.Possibly but we are stuck for terminology here. It's hard to think of a good term that reflects the intention.
You make several good points. How about:
* Rename __GFP_USER to __GFP_EASYRCLM
* Shift the two __GFP_*RCLM flags up to 0x80000u and 0x100000u
* Leave __GFP_BITS_SHIFT at the 21 in your patch (and fix its comment)
(or should we go up the next nibble, to 24?).
This results in the two key GFP defines being:
#define __GFP_EASYRCLM 0x80000u /* Easily reclaimed user or buffer page */
#define __GFP_KERNRCLM 0x100000u /* Reclaimable kernel page */
--
I won't rest till it's the best ...
Programmer, Linux Scalability
Paul Jackson [off-list ref] 1.925.600.0401
--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@kvack.org. For more info on Linux MM,
see: http://www.linux-mm.org/ .
Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>