From: Wang Qing <hidden> Date: 2021-03-01 06:35:11
The copy_to_user() function returns the number of bytes remaining to be
copied, but we want to return -EFAULT if the copy doesn't complete.
Signed-off-by: Wang Qing <redacted>
---
arch/mips/sibyte/common/sb_tbprof.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
From: "Maciej W. Rozycki" <macro@orcam.me.uk> Date: 2021-03-02 07:11:32
On Mon, 1 Mar 2021, Sergei Shtylyov wrote:
quoted
The copy_to_user() function returns the number of bytes remaining to be
copied, but we want to return -EFAULT if the copy doesn't complete.
Then 'err' is hardly a good name for that variable. :-)
Something like `left' might be better, especially as it's the sole use.
Also it's been like this from the beginning, so:
Fixes: bb9b813bb665 ("[MIPS] Sibyte: Fix ZBbus profiler")
or maybe:
Fixes: d619f38fdacb ("[MIPS] Add bcm1480 ZBus trace support, fix wait related bugs")
(since the file was renamed from a different name with the latter commit)
would I think be helpful for backports too. It looks like potentially
quite a nasty bug to me if someone actually uses this piece (I haven't).
Maciej