Re: [RESEND 00/26] Rid W=1 warnings from GPU
From: Daniel Vetter <hidden>
Date: 2021-06-03 11:35:07
Also in:
amd-gfx, dri-devel, linux-arm-msm, linux-media, linux-samsung-soc, lkml, nouveau
On Wed, Jun 02, 2021 at 03:32:34PM +0100, Lee Jones wrote:
Some off these patches have been knocking around for a while.
Who will hoover them up please?
This set is part of a larger effort attempting to clean-up W=1
kernel builds, which are currently overwhelmingly riddled with
niggly little warnings.
Lee Jones (26):
drm/mediatek/mtk_disp_color: Strip incorrect doc and demote header
drm/mediatek/mtk_disp_gamma: Strip and demote non-conformant
kernel-doc header
drm/mediatek/mtk_disp_ovl: Strip and demote non-conformant header
drm/mediatek/mtk_disp_rdma: Strip and demote non-conformant kernel-doc
header
drm/sti/sti_hdmi_tx3g4c28phy: Provide function names for kernel-doc
headers
drm/sti/sti_hda: Provide missing function names
drm/sti/sti_tvout: Provide a bunch of missing function names
drm/sti/sti_hqvdp: Fix incorrectly named function 'sti_hqvdp_vtg_cb()'
drm/msm/disp/dpu1/dpu_encoder_phys_cmd: Remove unused variable
'cmd_enc'
drm/msm/disp/dpu1/dpu_hw_interrupts: Demote a bunch of kernel-doc
abuses
drm/msm/disp/dpu1/dpu_plane: Fix a couple of naming issues
drm/msm/msm_gem: Demote kernel-doc abuses
drm/msm/dp/dp_catalog: Correctly document param 'dp_catalog'
drm/msm/dp/dp_link: Fix some potential doc-rot
drm/nouveau/nvkm/subdev/mc/tu102: Make functions called by reference
static
drm/amd/display/dc/dce/dce_transform: Remove superfluous
re-initialisation of DCFE_MEM_LIGHT_SLEEP_CNTL,
drm/xlnx/zynqmp_disp: Fix incorrectly named enum
'zynqmp_disp_layer_id'
drm/xlnx/zynqmp_dp: Fix incorrectly name function 'zynqmp_dp_train()'
drm/ttm/ttm_tt: Demote non-conformant kernel-doc header
drm/panel/panel-raspberrypi-touchscreen: Demote kernel-doc abuse
drm/panel/panel-sitronix-st7701: Demote kernel-doc abuse
drm/vgem/vgem_drv: Standard comment blocks should not use kernel-doc
format
drm/exynos/exynos7_drm_decon: Fix incorrect naming of
'decon_shadow_protect_win()'
drm/exynos/exynos_drm_ipp: Fix documentation for
'exynos_drm_ipp_get_{caps,res}_ioctl()'
drm/vboxvideo/hgsmi_base: Place function names into headers
drm/vboxvideo/modesetting: Provide function names for prototype
headersExcept for msm (Rob Clark promised on irc he'll pick them up for 5.14 soon) and amd (Alex is on top of things I think) I picked them all up and merged into drm-misc-next. Thanks, Daniel
.../drm/amd/display/dc/dce/dce_transform.h | 3 +- drivers/gpu/drm/exynos/exynos7_drm_decon.c | 2 +- drivers/gpu/drm/exynos/exynos_drm_ipp.c | 4 +-- drivers/gpu/drm/mediatek/mtk_disp_color.c | 3 +- drivers/gpu/drm/mediatek/mtk_disp_gamma.c | 4 +-- drivers/gpu/drm/mediatek/mtk_disp_ovl.c | 3 +- drivers/gpu/drm/mediatek/mtk_disp_rdma.c | 4 +-- .../drm/msm/disp/dpu1/dpu_encoder_phys_cmd.c | 4 --- .../gpu/drm/msm/disp/dpu1/dpu_hw_interrupts.c | 32 +++++++++---------- drivers/gpu/drm/msm/disp/dpu1/dpu_plane.c | 4 +-- drivers/gpu/drm/msm/dp/dp_catalog.c | 2 +- drivers/gpu/drm/msm/dp/dp_link.c | 6 ++-- drivers/gpu/drm/msm/msm_gem.c | 4 +-- .../gpu/drm/nouveau/nvkm/subdev/mc/tu102.c | 6 ++-- .../drm/panel/panel-raspberrypi-touchscreen.c | 2 +- drivers/gpu/drm/panel/panel-sitronix-st7701.c | 2 +- drivers/gpu/drm/sti/sti_hda.c | 6 ++-- drivers/gpu/drm/sti/sti_hdmi_tx3g4c28phy.c | 4 +-- drivers/gpu/drm/sti/sti_hqvdp.c | 2 +- drivers/gpu/drm/sti/sti_tvout.c | 18 +++++------ drivers/gpu/drm/ttm/ttm_tt.c | 2 +- drivers/gpu/drm/vboxvideo/hgsmi_base.c | 19 +++++++---- drivers/gpu/drm/vboxvideo/modesetting.c | 20 +++++++----- drivers/gpu/drm/vgem/vgem_drv.c | 2 +- drivers/gpu/drm/xlnx/zynqmp_disp.c | 2 +- drivers/gpu/drm/xlnx/zynqmp_dp.c | 2 +- 26 files changed, 80 insertions(+), 82 deletions(-) Cc: Adam Jackson <redacted> Cc: Ajay Kumar <redacted> Cc: Akshu Agarwal <redacted> Cc: Alex Deucher <alexander.deucher@amd.com> Cc: Alistair Popple <apopple@nvidia.com> Cc: amd-gfx@lists.freedesktop.org Cc: AngeloGioacchino Del Regno <redacted> Cc: Benjamin Gaignard <redacted> Cc: Ben Skeggs <redacted> Cc: Ben Widawsky <redacted> Cc: Chandan Uddaraju <redacted> Cc: Christian Koenig <christian.koenig@amd.com> Cc: "Christian König" <christian.koenig@amd.com> Cc: Chun-Kuang Hu <chunkuang.hu@kernel.org> Cc: Daniel Vetter <redacted> Cc: David Airlie <redacted> Cc: dri-devel@lists.freedesktop.org Cc: Eric Anholt <redacted> Cc: Fabien Dessenne <redacted> Cc: freedreno@lists.freedesktop.org Cc: Hans de Goede <redacted> Cc: Harry Wentland <harry.wentland@amd.com> Cc: Huang Rui <ray.huang@amd.com> Cc: Hyun Kwon <redacted> Cc: Inki Dae <inki.dae@samsung.com> Cc: Jagan Teki <jagan@amarulasolutions.com> Cc: Joonyoung Shim <redacted> Cc: Krishna Manikandan <redacted> Cc: Krzysztof Kozlowski <redacted> Cc: Kuogee Hsieh <redacted> Cc: Kyungmin Park <kyungmin.park@samsung.com> Cc: Laurent Pinchart <laurent.pinchart@ideasonboard.com> Cc: Leo Li <sunpeng.li@amd.com> Cc: linaro-mm-sig@lists.linaro.org Cc: linux-arm-kernel@lists.infradead.org Cc: linux-arm-msm@vger.kernel.org Cc: linux-mediatek@lists.infradead.org Cc: linux-media@vger.kernel.org Cc: linux-samsung-soc@vger.kernel.org Cc: Marek Szyprowski <m.szyprowski@samsung.com> Cc: Matthias Brugger <matthias.bgg@gmail.com> Cc: Mauro Rossi <redacted> Cc: Michal Simek <redacted> Cc: nouveau@lists.freedesktop.org Cc: Philipp Zabel <p.zabel@pengutronix.de> Cc: Rob Clark <redacted> Cc: Sam Ravnborg <redacted> Cc: Sean Paul <sean@poorly.run> Cc: Seung-Woo Kim <sw0312.kim@samsung.com> Cc: Stephen Boyd <redacted> Cc: Sumit Semwal <sumit.semwal@linaro.org> Cc: Thierry Reding <redacted> Cc: Vincent Abriou <redacted> -- 2.31.1
-- Daniel Vetter Software Engineer, Intel Corporation http://blog.ffwll.ch _______________________________________________ Linux-mediatek mailing list Linux-mediatek@lists.infradead.org http://lists.infradead.org/mailman/listinfo/linux-mediatek