Re: [PATCH 3/7] media: imx274: don't hard-code the subdev name to DRIVER_NAME
From: Philippe De Muyter <hidden>
Date: 2018-08-30 06:58:19
Also in:
lkml
Hi. On Thu, Aug 30, 2018 at 12:23:23AM +0300, Laurent Pinchart wrote:
Hello, On Wednesday, 29 August 2018 14:38:43 EEST Sakari Ailus wrote:quoted
On Wed, Aug 29, 2018 at 01:29:36PM +0200, Philippe De Muyter wrote:quoted
On Wed, Aug 29, 2018 at 02:07:21PM +0300, Sakari Ailus wrote:quoted
On Tue, Aug 28, 2018 at 06:02:55PM +0200, Philippe De Muyter wrote:[snip]quoted
quoted
quoted
quoted
Then we should probably also apply the following patch I submitted : "media: v4l2-common: v4l2_spi_subdev_init : generate unique name" https://patchwork.kernel.org/patch/10553035/ and perhaps "media: v4l2-common: simplify v4l2_i2c_subdev_init name generation" https://patchwork.kernel.org/patch/10553037/The problem with this patch is that the existing naming scheme is very similar while the new one offers no tangible benefits apart from being in line with the rest of the kernel. That's still not a benefit for uAPI: changing the name is certain to break user space applications.I agree with you on the patch for v4l2_i2c_subdev_init (I wrote 'perhaps'), but you don't say anything on the one about v4l2_spi_subdev_init :), which fixes an actual bug. I have 2 identical SPI-controlled sensors on the same board, and without my patch they get the same subdev name. Of course, I could fix that in the sensor driver itself, but that's not what we want, or do we ?Good point. I missed the naming of the SPI devices ignored any bus information there. I'm rather inclined towards taking the SPI patch. Hans, Mauro, Laurent; any opinion on that?I agree that the SPI patch makes sense, I think we should take it.
Do I need to resend https://patchwork.kernel.org/patch/10553035/ "media: v4l2-common: v4l2_spi_subdev_init : generate unique name", adding Sakari's and Laurent's Acked-by ? or will that patch be taken automagically ? Philippe -- Philippe De Muyter +32 2 6101532 Macq SA rue de l'Aeronef 2 B-1140 Bruxelles