Em Mon, 5 Nov 2012 20:39:33 +0900
YAMANE Toshiaki [off-list ref] escreveu:
quoted hunk ↗ jump to hunk
fixed below checkpatch error.
- ERROR: trailing statements should be on next line
Signed-off-by: YAMANE Toshiaki <redacted>
---
drivers/staging/media/go7007/go7007-fw.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/drivers/staging/media/go7007/go7007-fw.c b/drivers/staging/media/go7007/go7007-fw.c
index f99c05b..cfce760 100644
--- a/drivers/staging/media/go7007/go7007-fw.c
+++ b/drivers/staging/media/go7007/go7007-fw.c
@@ -725,7 +725,8 @@ static int vti_bitlen(struct go7007 *go)
{
unsigned int i, max_time_incr = go->sensor_framerate / go->fps_scale;
- for (i = 31; (max_time_incr & ((1 << i) - 1)) == max_time_incr; --i);
+ for (i = 31; (max_time_incr & ((1 << i) - 1)) == max_time_incr; --i)
+ ;
Nah, this doesn't sound right to me. IMO, in this specific case,
checkpatch.pl did a bad job.
At least on my eyes, the first line is easier to read than the other
two ones.
return i + 1;
}
Regards,
Mauro