Re: [PATCH] media: davinci: vpif: set device capabilities
flat view
From: Hans Verkuil <hidden>
Date: 2012-09-25 11:54:56
Also in:
lkml
On Tue 25 September 2012 13:49:16 Laurent Pinchart wrote:
Hi Hans, On Tuesday 25 September 2012 13:43:36 Hans Verkuil wrote:quoted
On Tue 25 September 2012 13:16:24 Prabhakar wrote:quoted
From: Lad, Prabhakar <redacted> Signed-off-by: Lad, Prabhakar <redacted> Signed-off-by: Manjunath Hadli <redacted> Cc: Hans Verkuil <redacted> --- drivers/media/platform/davinci/vpif_capture.c | 4 +++- drivers/media/platform/davinci/vpif_display.c | 4 +++- 2 files changed, 6 insertions(+), 2 deletions(-)diff --git a/drivers/media/platform/davinci/vpif_capture.cb/drivers/media/platform/davinci/vpif_capture.c index 4828888..faeca98 100644--- a/drivers/media/platform/davinci/vpif_capture.c +++ b/drivers/media/platform/davinci/vpif_capture.c@@ -1630,7 +1630,9 @@ static int vpif_querycap(struct file *file, void*priv,> { struct vpif_capture_config *config = vpif_dev->platform_data; - cap->capabilities = V4L2_CAP_VIDEO_CAPTURE | V4L2_CAP_STREAMING; + cap->device_caps = V4L2_CAP_VIDEO_CAPTURE | V4L2_CAP_STREAMING | + V4L2_CAP_READWRITE; + cap->capabilities = cap->device_caps | V4L2_CAP_DEVICE_CAPS; strlcpy(cap->driver, "vpif capture", sizeof(cap->driver));This should be the real driver name which is 'vpif_capture'.quoted
strlcpy(cap->bus_info, "VPIF Platform", sizeof(cap->bus_info));For bus_info I would use: "platform:vpif_capture". The 'platform:' prefix is going to be the standard for platform drivers.What about snprintf(cap->driver, sizeof(cap->driver), "platform:%s", dev_name(vpif_dev)); That would handle cases where multiple platform devices of the same type are present.
Sure, that's even better. You do have to check that this gives you what you'd expect (i.e., that you don't end up with "platform:platform:vpif_capture"). Regards, Hans