Thread (25 messages) 25 messages, 4 authors, 2019-02-05

Re: [PATCH v9 2/6] tpm: rename and export tpm2_digest and tpm2_algorithms

flat view

From: Jarkko Sakkinen <hidden>
Date: 2019-02-01 13:36:25
Also in: keyrings, linux-security-module, lkml

On Fri, Feb 01, 2019 at 11:06:37AM +0100, Roberto Sassu wrote:
Rename tpm2_* to tpm_* and move the definitions to include/linux/tpm.h so
that these can be used by other kernel subsystems (e.g. IMA).

Also, set the length of the digest array in tpm_digest to a new constant
named TPM_MAX_DIGEST_SIZE, equal to SHA512_DIGEST_SIZE.

Signed-off-by: Roberto Sassu <roberto.sassu@huawei.com>
Reviewed-by: Jarkko Sakkinen <redacted>
Acked-by: Mimi Zohar <zohar@linux.ibm.com>
Tested-by: Jarkko Sakkinen <redacted>

/Jarkko
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help