Thread (12 messages) 12 messages, 6 authors, 2025-04-16

Re: [PATCH] HID: simplify code in fetch_item()

From: Benjamin Tissoires <bentiss@kernel.org>
Date: 2024-10-04 12:05:12
Also in: lkml

On Tue, 01 Oct 2024 08:42:36 -0700, Dmitry Torokhov wrote:
We can easily calculate the size of the item using arithmetic (shifts).
This allows to pull duplicated code out of the switch statement, making
it cleaner.
Applied to hid/hid.git (for-6.13/core), thanks!

[1/1] HID: simplify code in fetch_item()
      https://git.kernel.org/hid/hid/c/61595012f280

Cheers,
-- 
Benjamin Tissoires [off-list ref]
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help