Thread (3 messages) flat view 3 messages, 2 authors, 2023-05-26

Re: [PATCH] Input: Switch i2c drivers back to use .probe()

From: Uwe Kleine-König <hidden>
Date: 2023-05-26 15:56:53

Hello Dmitry,

On Wed, May 17, 2023 at 10:02:17AM -0700, Dmitry Torokhov wrote:
On Wed, May 17, 2023 at 06:46:45PM +0200, Uwe Kleine-König wrote:
quoted
After commit b8a1a4cd5a98 ("i2c: Provide a temporary .probe_new()
call-back type"), all drivers being converted to .probe_new() and then
03c835f498b5 ("i2c: Switch .probe() to not take an id parameter") convert
back to (the new) .probe() to be able to eventually drop .probe_new() from
struct i2c_driver.

Signed-off-by: Uwe Kleine-König <redacted>
---
Hello,

this patch was generated using coccinelle, but I aligned the result to
the per-file indention. Other than that it's just s/probe_new/probe/.

I used v6.4-rc1 as base for it, there are a few patches in next that
conflict slightly with it, but for me git can sort it all out.
Feel free to just drop all conflicting hunks if it doesn't go so smooth
for you, I'll care about the fallout later.
I think I saw only 1 clash in cyttsp5 driver, and I resolved it.
Hopefully I did not miss anything else.

This is now applied for the next merge window.
FTR: Looking at commit d8bde56dfd86 ("Input: Switch i2c drivers back to
use .probe()") which is in next-20230525, everything seems to be right.

Thanks
Uwe

-- 
Pengutronix e.K.                           | Uwe Kleine-König            |
Industrial Linux Solutions                 | https://www.pengutronix.de/ |

Attachments

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help