Re: [PATCH 2/2] Input: ili210x - add ILI2117 support
From: Dmitry Torokhov <dmitry.torokhov@gmail.com>
Date: 2019-11-12 00:19:48
Also in:
lkml
On Mon, Nov 11, 2019 at 12:43:19PM -0600, Rob Herring wrote:
On Mon, Nov 11, 2019 at 12:17 PM Dmitry Torokhov [off-list ref] wrote:quoted
On Tue, Nov 05, 2019 at 10:29:53AM -0500, Sven Van Asbroeck wrote:quoted
On Mon, Nov 4, 2019 at 6:36 PM Dmitry Torokhov [off-list ref] wrote:quoted
OK, I refreshed the branch with fixes and a couple of new patches. It is on top of 5.3 now. If this works for you guys I will be merging it for 5.5.According to the ili2117a/2118a datasheet I have, there are still a few loose ends. Some of these might be too inconsequential to worry about. Dmitry, tell me which ones you think are important, if any, and I will spin a patch if you like. Or you can do it, just let me know.quoted
{ "ili210x", (long)&ili210x_chip }, { "ili2117", (long)&ili211x_chip }, { "ili251x", (long)&ili251x_chip }, { .compatible = "ilitek,ili210x", .data = &ili210x_chip }, { .compatible = "ilitek,ili2117", .data = &ili211x_chip }, { .compatible = "ilitek,ili251x", .data = &ili251x_chip },My datasheet says ILI2117A/ILI2118A, so maybe the compatible string should really be "ilitek,ili211x", just like the other variants ?We have not landed the DT for 2117, so we can either rename it as "ilitek,ili211x" or have 2 separate compatibles. Rob, do you have preference?The rule is we don't do wildcards for compatible strings. However, if there's not a visible difference to s/w or you can determine which is which by ID registers, then it is fine to have a single compatible. I couldn't find a datasheet, so can't give better answer.
OK, so I merged the branch keeping ilitek,ili2117 compatible. Sven, please feel free to send the patches addressing issues you discovered and I will be glad to apply them. Thanks. -- Dmitry