Thread (20 messages) 20 messages, 4 authors, 2018-06-19

Re: [PATCH 01/11] i2c: add helpers for locking the I2C segment

From: Wolfram Sang <hidden>
Date: 2018-06-18 11:54:59
Also in: linux-arm-kernel, linux-i2c, linux-iio, linux-integrity, linux-media, linux-samsung-soc, linux-tegra, lkml

quoted
I wonder if i2c_lock_segment() and i2c_lock_root_adapter() are really
more readable and convenient than i2c_lock_bus() with the flag. I think
the flags have speaking names, too.

Is that an idea to remove these functions altogether and start using
i2c_lock_bus()?
That would be fine with me. I don't have a strong opinion and agree that
both are readable enough...

It would make for a reduction of the number of lines so that's nice, but
the macro in drivers/i2c/busses/i2c-gpio.c (patch 11) would not fit in
the current \-width (or whatever you'd call that line of backslashes to
the right in a multi-line macro).

Does anyone have a strong opinion?
I have a strong opinion on making i2c.h less bloated. And yes, less
number of lines is nice, too. I think that surely pays off the
whitespace exception.

Thanks!

Attachments

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help