Charles Keepax [off-list ref] writes:
On Wed, Oct 26, 2016 at 09:41:45PM +0200, Robert Jarzmik wrote:
quoted
diff --git a/drivers/input/touchscreen/wm97xx-core.c b/drivers/input/touchscreen/wm97xx-core.c
index 83cf11312fd9..50a110e2988b 100644
<snip>
quoted
+static void wm97xx_remove_battery(struct wm97xx *wm)
+{
+ platform_device_put(wm->battery_dev);
+}
<snip>
quoted
@@ -724,10 +757,8 @@ static int wm97xx_remove(struct device *dev)
{
struct wm97xx *wm = dev_get_drvdata(dev);
- platform_device_unregister(wm->battery_dev);
- platform_device_unregister(wm->touch_dev);
- input_unregister_device(wm->input_dev);
- kfree(wm);
+ wm97xx_remove_battery(wm);
The commit message says this is just shifting code around but the
platform_device_unregister for the battery_dev seems to have
turned into a platform_device_put here.
Thanks for spotting that, it's clearly a defect in the patch.
That implies a v2 at least for this one.
Cheers.
--
Robert