The binding should be for a class of hardware, not for a driver. Please
describe the class of hardware the binding represents, and remove
references to the Linux driver.
Will do.
quoted
+Required properties:
+ - compatible = "gpio-joy";
That does not strike me as a very informative compatible string. At the least,
s/joy/joystick/.
You're very right, gpio-joystick is better and as about as specific as it can be I believe.
quoted
+
+ - left-gpio : gpio connected to the "left" joystick signal
+ - right-gpio : gpio connected to the "right" joystick signal
+ - up-gpio : gpio connected to the "up" joystick signal
+ - down-gpio : gpio connected to the "down" joystick signal
+ - button-gpio : gpio connected to the "button" joystick signal
Only one button?
Hmm, yes, but it would make more sense to have sub-nodes defining an arbitrary
number of buttons instead, right?
Thanks for reviewing!
Hans