Hi ELias,
On Mon, Sep 08, 2014 at 08:14:13PM +0200, Elias Vanderstuyft wrote:
Hi everyone,
After inspecting the <linux/input.h> header file, I found that there
is one single ioctl value macro that is inconsistent w.r.t. the other
macros that do an IOC_WRITE :
EVIOCSFF _IOC(_IOC_WRITE, 'E', 0x80, sizeof(struct ff_effect))
Why not define it as follows? :
EVIOCSFF _IOW('E', 0x80, struct ff_effect)
Apart from having a more readable definition, it also explicitly
reveals type info ("struct ff_effect").
I think it is just historical.
Is it worth to create a patch to fix it?
Sure, why not.
Thanks.
--
Dmitry