Re: [PATCH 01/14] HID: uHID: remove duplicated code
From: David Herrmann <hidden>
Date: 2014-02-12 10:17:24
Also in:
lkml
Hi On Mon, Feb 10, 2014 at 6:58 PM, Benjamin Tissoires [off-list ref] wrote:
quoted hunk ↗ jump to hunk
uhid_hid_output_report() can be implemented through a simple call to uhid_hid_output_raw(). Signed-off-by: Benjamin Tissoires <redacted> --- drivers/hid/uhid.c | 22 +--------------------- 1 file changed, 1 insertion(+), 21 deletions(-)diff --git a/drivers/hid/uhid.c b/drivers/hid/uhid.c index 12439e1..b6de903 100644 --- a/drivers/hid/uhid.c +++ b/drivers/hid/uhid.c@@ -247,27 +247,7 @@ static int uhid_hid_output_raw(struct hid_device *hid, __u8 *buf, size_t count, static int uhid_hid_output_report(struct hid_device *hid, __u8 *buf, size_t count) { - struct uhid_device *uhid = hid->driver_data; - unsigned long flags; - struct uhid_event *ev; - - if (count < 1 || count > UHID_DATA_MAX) - return -EINVAL; - - ev = kzalloc(sizeof(*ev), GFP_KERNEL); - if (!ev) - return -ENOMEM; - - ev->type = UHID_OUTPUT; - ev->u.output.size = count; - ev->u.output.rtype = UHID_OUTPUT_REPORT; - memcpy(ev->u.output.data, buf, count); - - spin_lock_irqsave(&uhid->qlock, flags); - uhid_queue(uhid, ev); - spin_unlock_irqrestore(&uhid->qlock, flags); - - return count; + return uhid_hid_output_raw(hid, buf, count, HID_OUTPUT_REPORT);
Took me a while to see that we have: HID_OUTPUT_REPORT UHID_OUTPUT_REPORT .. gnah! I should have named the uhid stuff better.. anyhow, patch looks good: Reviewed-by: David Herrmann <redacted> Thanks David
}
static struct hid_ll_driver uhid_hid_driver = {
--
1.8.3.1