On Mon, May 27, 2013 at 09:12:03PM +0200, Sebastian Andrzej Siewior wrote:
quoted hunk
tsc is a very generic name. This patch adds a TI prefix to make it a
little less generic.
While here add an alias so the driver is loaded on demand.
Signed-off-by: Sebastian Andrzej Siewior <redacted>
---
drivers/input/touchscreen/ti_am335x_tsc.c | 3 ++-
drivers/mfd/ti_am335x_tscadc.c | 2 +-
2 files changed, 3 insertions(+), 2 deletions(-)
diff --git a/drivers/input/touchscreen/ti_am335x_tsc.c b/drivers/input/touchscreen/ti_am335x_tsc.c
index 96accaa..2921163 100644
--- a/drivers/input/touchscreen/ti_am335x_tsc.c
+++ b/drivers/input/touchscreen/ti_am335x_tsc.c
@@ -543,11 +543,12 @@ static struct platform_driver ti_tsc_driver = {
.probe = titsc_probe,
.remove = titsc_remove,
.driver = {
- .name = "tsc",
+ .name = "TI-tsc",
Still quite generic... Why not call it "TI-am335x-tsc"?
Thanks.
--
Dmitry