Thread (10 messages) 10 messages, 2 authors, 2012-12-02

Re: [PATCH 1/4] Input RMI4 - rename rmi_function_container to rmi_function

flat view

From: Christopher Heiny <hidden>
Date: 2012-11-27 23:43:11
Also in: lkml

On 11/27/2012 01:21 AM, Dmitry Torokhov wrote:
To save my old fingers...

Signed-off-by: Dmitry Torokhov<dmitry.torokhov@gmail.com>
---

It looks like this driver(s) need some love and I might have some time so I
will refresh my "synaptics" branch with the patches you have sent and start
working off it. If you have updates I would appreciate if you also make them
available relative to that branch. When we are ready we'll squash them all
together and apply to the official branch.
No problem - let me know which branch/tag to work with, and we'll be happy to patch against that for the next round.
quoted hunk ↗ jump to hunk
Thanks.

  drivers/input/rmi4/rmi_driver.c | 158 +++++++++++----------
  drivers/input/rmi4/rmi_driver.h |   4 +-
  drivers/input/rmi4/rmi_f01.c    | 298 ++++++++++++++++++++--------------------
  drivers/input/rmi4/rmi_f11.c    | 258 +++++++++++++++++-----------------
  include/linux/rmi.h             |  22 ++-
  5 files changed, 368 insertions(+), 372 deletions(-)
diff --git a/drivers/input/rmi4/rmi_driver.c b/drivers/input/rmi4/rmi_driver.c
index 05a73ae..e8a4b52 100644
--- a/drivers/input/rmi4/rmi_driver.c
+++ b/drivers/input/rmi4/rmi_driver.c
@@ -594,7 +594,7 @@ static struct device_attribute bsr_attribute = __ATTR(bsr, RMI_RW_ATTR,

  static void rmi_free_function_list(struct rmi_device *rmi_dev)
  {
-	struct rmi_function_container *entry, *n;
+	struct rmi_function *entry, *n;
  	struct rmi_driver_data *data = dev_get_drvdata(&rmi_dev->dev);

  	if (!data) {
@@ -613,44 +613,44 @@ static void rmi_free_function_list(struct rmi_device *rmi_dev)
  	}
  }

-static void release_fc_device(struct device *dev)
+static void release_function_device(struct device *dev)
  {
  	dev_dbg(dev, "REMOVING KOBJ!");
  	kobject_put(&dev->kobj);
  }
Hmmm.  Since rmi_function_container has evolved into a child device of the RMI4 module, maybe it would be better renamed rmi_function_device or rmi_function_dev?  I find this clearer, but can live with just rmi_function if you prefer that.


Similarly, rmi_function_handler has evolved into a driver for such devices, so perhaps it should be renamed rmi_function_driver?

[snip]
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help