On Wed, 5 Sep 2012, Axel Lin wrote:
quoted hunk ↗ jump to hunk
Signed-off-by: Axel Lin <redacted>
---
drivers/hid/hid-lcpower.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/hid/hid-lcpower.c b/drivers/hid/hid-lcpower.c
index c4fe9bd0..22bc14a 100644
--- a/drivers/hid/hid-lcpower.c
+++ b/drivers/hid/hid-lcpower.c
@@ -24,7 +24,7 @@ static int ts_input_mapping(struct hid_device *hdev, struct hid_input *hi,
struct hid_field *field, struct hid_usage *usage,
unsigned long **bit, int *max)
{
- if ((usage->hid & HID_USAGE_PAGE) != 0x0ffbc0000)
+ if ((usage->hid & HID_USAGE_PAGE) != HID_UP_LOGIVENDOR)
return 0;
switch (usage->hid & HID_USAGE) {
The name of the actual constant is quite losing its point with more and
more non-Logitech devices using this usage page.
I am applying your patch now, but I guess we'll rather rename the define
in a near future.
Thanks,
--
Jiri Kosina
SUSE Labs