Thread (8 messages) flat view 8 messages, 3 authors, 2012-06-28

Re: [PATCH 1/3] HID: hid-multitouch: fix input mode feature command

From: Jiri Kosina <hidden>
Date: 2012-06-28 08:31:21
Also in: lkml

On Tue, 19 Jun 2012, benjamin.tissoires wrote:
From: Benjamin Tissoires <redacted>

Zytronic panels shows a new way of setting the Input Mode feature.
This feature is put in the second usage in the HID feature, instead
of the first, as the majority of the multitouch devices.

This patch adds a detection step when the feature is presented to know
where the feature is located in the report. We can then trigger the right
command to the device. This removes the magic number "0" in the function
mt_set_input_mode.
I have applied 1/3 and 3/3. For 2/3, Henrik raised concern which I'd like 
to have resolved first.

Thanks!

-- 
Jiri Kosina
SUSE Labs
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help