Thread (20 messages) flat view 20 messages, 4 authors, 2012-05-25

Re: [git pull] Input updates for 3.5-rc0

From: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Date: 2012-05-24 21:36:09
Also in: lkml

On Thu, May 24, 2012 at 10:33:49AM -0700, Linus Torvalds wrote:
On Thu, May 24, 2012 at 1:32 AM, Dmitry Torokhov
[off-list ref] wrote:
quoted
Hi Linus,

to receive updates for the input subsystem. You will get:
I get an annoying conflict, and the reason I call it annoying is not
because it's hard to resolve, it's because doing that shows that you
seem to have preferred using

   dev_dbg(&input->dev.parent, ...)

over the much more natural

   dev_dbg(&input->dev, ...)

which would seem to make more sense.

Why? Are the input layer device names so bad that using them for debug
output is useless? And if so, why *are* they so bad?

I'm going to take your version over Greg's more straightforward one,
because I assume Greg did things a bit more mindlessly and I think you
presumably had a *reason* for your extra (stupid) ".parent" part. But
I'm unhappy with it, because I suspect the reason you did that implies
that the input layer does something bad.
I reworked these patches 3 different times, they were anything but
"mindless" (well, maybe the first ones were...)  Dmitry and I seem to
disagree on showing useful names to the users, but as he is the one who
needs to handle user issues when they report things, I'll defer to his
version of the changes.

thanks,

greg k-h
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help