On 3/29/12, Stephen Warren [off-list ref] wrote:
On 03/29/2012 02:33 AM, Viresh Kumar wrote:
quoted
+static struct tegra_kbc_platform_data *
+__devinit tegra_kbc_dt_parse_pdata(struct device_node *np)
I'd be tempted to keep __devinit on the first line, but not a big deal.
I need to send V4. So will do this too. :)
quoted
+int matrix_keypad_of_build_keymap(struct input_dev *idev,
+ unsigned int row_shift, const char *propname)
quoted
+ size = proplen / sizeof(u32);
+ if (size > idev->keycodemax) {
+ dev_err(dev, "OF: %s overflow\n", propname);
+ return -EINVAL;
}
That is checking the number of entries in the property, not the values
of the MATRIX_SCAN_CODE values derived from those entries. I'd say just
remove this check. See below.
Absolutely correct.
--
Viresh