[PATCH] Input: zylonite-wm97xx - replace IRQ_GPIO() with gpio_to_irq()

Subsystems: input (keyboard, mouse, joystick, touchscreen) drivers, the rest

STALE5396d

5 messages, 4 authors, 2011-12-06 · open the first message on its own page

[PATCH] Input: zylonite-wm97xx - replace IRQ_GPIO() with gpio_to_irq()

From: Axel Lin <hidden>
Date: 2011-12-05 11:13:21

Since commit 6384fd "ARM: pxa: rename IRQ_GPIO to PXA_GPIO_TO_IRQ",
I got below buid errors due to implicit declaration of function 'IRQ_GPIO'.

Use common gpio_to_irq() to replace machine dependant macro IRQ_GPIO().

  CC      drivers/input/touchscreen/zylonite-wm97xx.o
drivers/input/touchscreen/zylonite-wm97xx.c: In function 'zylonite_wm97xx_probe':
drivers/input/touchscreen/zylonite-wm97xx.c:195: error: implicit declaration of function 'IRQ_GPIO'
make[3]: *** [drivers/input/touchscreen/zylonite-wm97xx.o] Error 1
make[2]: *** [drivers/input/touchscreen] Error 2
make[1]: *** [drivers/input] Error 2
make: *** [drivers] Error 2

Cc: Mark Brown <redacted>
Cc: Haojian Zhuang <redacted>
Signed-off-by: Axel Lin <redacted>
---
I got the build error in linux-next tree,
thus this patch is against linux-next (20111205).

Axel
 drivers/input/touchscreen/zylonite-wm97xx.c |    5 +++--
 1 files changed, 3 insertions(+), 2 deletions(-)
diff --git a/drivers/input/touchscreen/zylonite-wm97xx.c b/drivers/input/touchscreen/zylonite-wm97xx.c
index add6e3b..bf0869a7 100644
--- a/drivers/input/touchscreen/zylonite-wm97xx.c
+++ b/drivers/input/touchscreen/zylonite-wm97xx.c
@@ -22,6 +22,7 @@
 #include <linux/kernel.h>
 #include <linux/init.h>
 #include <linux/delay.h>
+#include <linux/gpio.h>
 #include <linux/irq.h>
 #include <linux/interrupt.h>
 #include <linux/io.h>
@@ -192,8 +193,8 @@ static int zylonite_wm97xx_probe(struct platform_device *pdev)
 	else
 		gpio_touch_irq = mfp_to_gpio(MFP_PIN_GPIO26);
 
-	wm->pen_irq = IRQ_GPIO(gpio_touch_irq);
-	irq_set_irq_type(IRQ_GPIO(gpio_touch_irq), IRQ_TYPE_EDGE_BOTH);
+	wm->pen_irq = gpio_to_irq(gpio_touch_irq);
+	irq_set_irq_type(wm->pen_irq, IRQ_TYPE_EDGE_BOTH);
 
 	wm97xx_config_gpio(wm, WM97XX_GPIO_13, WM97XX_GPIO_IN,
 			   WM97XX_GPIO_POL_HIGH,
-- 
1.7.5.4


Re: [PATCH] Input: zylonite-wm97xx - replace IRQ_GPIO() with gpio_to_irq()

From: Haojian Zhuang <haojian.zhuang@gmail.com>
Date: 2011-12-05 11:30:57

On Mon, Dec 5, 2011 at 7:13 PM, Axel Lin [off-list ref] wrote:
quoted hunk
Since commit 6384fd "ARM: pxa: rename IRQ_GPIO to PXA_GPIO_TO_IRQ",
I got below buid errors due to implicit declaration of function 'IRQ_GPIO'.

Use common gpio_to_irq() to replace machine dependant macro IRQ_GPIO().

 CC      drivers/input/touchscreen/zylonite-wm97xx.o
drivers/input/touchscreen/zylonite-wm97xx.c: In function 'zylonite_wm97xx_probe':
drivers/input/touchscreen/zylonite-wm97xx.c:195: error: implicit declaration of function 'IRQ_GPIO'
make[3]: *** [drivers/input/touchscreen/zylonite-wm97xx.o] Error 1
make[2]: *** [drivers/input/touchscreen] Error 2
make[1]: *** [drivers/input] Error 2
make: *** [drivers] Error 2

Cc: Mark Brown <redacted>
Cc: Haojian Zhuang <redacted>
Signed-off-by: Axel Lin <redacted>
---
I got the build error in linux-next tree,
thus this patch is against linux-next (20111205).

Axel
 drivers/input/touchscreen/zylonite-wm97xx.c |    5 +++--
 1 files changed, 3 insertions(+), 2 deletions(-)
diff --git a/drivers/input/touchscreen/zylonite-wm97xx.c b/drivers/input/touchscreen/zylonite-wm97xx.c
index add6e3b..bf0869a7 100644
--- a/drivers/input/touchscreen/zylonite-wm97xx.c
+++ b/drivers/input/touchscreen/zylonite-wm97xx.c
@@ -22,6 +22,7 @@
 #include <linux/kernel.h>
 #include <linux/init.h>
 #include <linux/delay.h>
+#include <linux/gpio.h>
 #include <linux/irq.h>
 #include <linux/interrupt.h>
 #include <linux/io.h>
@@ -192,8 +193,8 @@ static int zylonite_wm97xx_probe(struct platform_device *pdev)
       else
               gpio_touch_irq = mfp_to_gpio(MFP_PIN_GPIO26);

-       wm->pen_irq = IRQ_GPIO(gpio_touch_irq);
-       irq_set_irq_type(IRQ_GPIO(gpio_touch_irq), IRQ_TYPE_EDGE_BOTH);
+       wm->pen_irq = gpio_to_irq(gpio_touch_irq);
+       irq_set_irq_type(wm->pen_irq, IRQ_TYPE_EDGE_BOTH);

       wm97xx_config_gpio(wm, WM97XX_GPIO_13, WM97XX_GPIO_IN,
                          WM97XX_GPIO_POL_HIGH,
--
Acked-by: Haojian Zhuang <haojian.zhuang@gmail.com>
--
To unsubscribe from this list: send the line "unsubscribe linux-input" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Re: [PATCH] Input: zylonite-wm97xx - replace IRQ_GPIO() with gpio_to_irq()

From: Mark Brown <hidden>
Date: 2011-12-05 11:50:58

On Mon, Dec 05, 2011 at 07:13:12PM +0800, Axel Lin wrote:
Since commit 6384fd "ARM: pxa: rename IRQ_GPIO to PXA_GPIO_TO_IRQ",
I got below buid errors due to implicit declaration of function 'IRQ_GPIO'.
Acked-by: Mark Brown <redacted>

I guess that for bisection this should go via Eric's tree as it
introduced the issue.

Re: [PATCH] Input: zylonite-wm97xx - replace IRQ_GPIO() with gpio_to_irq()

From: Haojian Zhuang <haojian.zhuang@gmail.com>
Date: 2011-12-06 04:58:39

On Mon, Dec 5, 2011 at 7:50 PM, Mark Brown
[off-list ref] wrote:
On Mon, Dec 05, 2011 at 07:13:12PM +0800, Axel Lin wrote:
quoted
Since commit 6384fd "ARM: pxa: rename IRQ_GPIO to PXA_GPIO_TO_IRQ",
I got below buid errors due to implicit declaration of function 'IRQ_GPIO'.
Acked-by: Mark Brown <redacted>

I guess that for bisection this should go via Eric's tree as it
introduced the issue.
--
Sure. We'll handle it.

Best Regards
Haojian

Re: [PATCH] Input: zylonite-wm97xx - replace IRQ_GPIO() with gpio_to_irq()

From: Dmitry Torokhov <dmitry.torokhov@gmail.com>
Date: 2011-12-06 05:29:28

On Tue, Dec 06, 2011 at 12:58:36PM +0800, Haojian Zhuang wrote:
On Mon, Dec 5, 2011 at 7:50 PM, Mark Brown
[off-list ref] wrote:
quoted
On Mon, Dec 05, 2011 at 07:13:12PM +0800, Axel Lin wrote:
quoted
Since commit 6384fd "ARM: pxa: rename IRQ_GPIO to PXA_GPIO_TO_IRQ",
I got below buid errors due to implicit declaration of function 'IRQ_GPIO'.
Acked-by: Mark Brown <redacted>

I guess that for bisection this should go via Eric's tree as it
introduced the issue.
--
Sure. We'll handle it.
Thanks!

-- 
Dmitry
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help