Re: [PATCH v2] input: add EETI eGalax I2C capacitive multi touch driver.
flat view
From: Jiejing.Zhang <hidden>
Date: 2011-09-08 11:39:21
Hi Henrik, 2011/8/13 Henrik Rydberg [off-list ref]:
quoted
quoted
The device seems to send finger changes sequentually, resulting in one packet (terminated with input sync) for each finger change. Is this the intention/necessary? Some egalax firmware (hid version) seems to work this way.When I make v2 patch, I've a look the Protocol B's driver in upstream, but there were two type of multi-point report fashion, One type is report all the finger status in one input sync(), and separate each mt point with mt_input_slot(), like wocom driver. But there was some driver (like egalax hid version), send each mt point with one input_sync(), but I'm worry about if main stream user space frameworks(xorg mtouch etc,) support this behavior well.Sequential reporting works reasonably well, although there are potential problems (applying methods for smooth motion, for instance). Wakeups and cpu intensity also increases.quoted
What's your point of view about this ?If possible, I think batched reporting is preferred, i.e., using the same method as all hid drivers _but_ the egalax one.
After go through the code, I found HID driver's batched report is hard to implement in this driver. Although, since I already use threaded irq to deal with the new event information, and it will perform i2c read every time, i2c is a slow bus, I think the CPU cause of this kind of device is relative lower then some device via USB.
quoted
quoted
The usage of REPORT_MODE_* is unclear to me too.In the programming manual this mode 's name is "single touch mouse mode", may be it will be a better name for this mode ?Ok, sounds like the equivalent of the hid generic mouse, which could either be ignored or assigned its own input device node. Nothing out of the ordinary, in other words, and the patch looks good in this respect. Thanks for clarifying.
I've already change the MODE_SINGLE to MODE_MOUSE to avoid confusion in next version.
Henrik
Thanks, Jiejing