Thread (1 message) 1 message, 1 author, 2009-12-03

Re: [Kde-hardware-devel] [PATCH 32/33] input: add KEY_WIRELESS_CYCLE

From: Will Stephenson <hidden>
Date: 2009-12-03 11:23:04
Also in: linux-acpi, linux-wireless

On Thursday 03 December 2009 10:43:32 Johannes Berg wrote:
On Thu, 2009-12-03 at 10:22 +0100, Corentin Chary wrote:
quoted
Dear system infrastructure people,
Do you think a KEY_WIRELESS_CYCLE key would have any application ?
Not really.

The naming of the key ultimately will not matter one bit, because it'll
be misnamed on most platforms anyway, unless we want to do DMI matching
or something to name the key. And even then, if there's a wifi key but
no bluetooth key, users may prefer to have the wifi key act as a cycle
key instead.

Therefore, this ought to all be policy in the rfkill daemon.
rfkill-input will be going away as soon as somebody writes a simple
daemon that allows doing such things, I really don't see us adding
support for a cycle key to the kernel code, and for the userspace code
it doesn't matter since users will configure it independent of the key
code anyway.
This sounds reasonable to me, as the wireless guy in the KDE camp.  I don't 
want to have to handle these keypresses in a user session anyway - I prefer 
that NetworkManager picks up on them and notifies the client of the state 
change.

Will
--
To unsubscribe from this list: send the line "unsubscribe linux-wireless" in
the body of a message to majordomo-u79uwXL29TY76Z2rM5mHXA@public.gmane.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help