Jeff,
2) If we are going to unconditionally add ATA_SECT_SIZE bytes to every
ata_device structure, let's at least move the ata_read_log_page() call
outside of the devslp test, so that others may have this information
even if the device does not support devslp.
Agreed, the info in that page is not limited to DevSlp variables.
Should I also move it outside of the ata_dev_configure() function?
Do you have better place to suggest?
3) please define constants in linux/ata.h for sata_settings information,
rather than using hexidecimal constants ("magic numbers").
OK, I will define ATA_ID_FEATURE_SUPP to replace all the 78.
4) is it wise to issue SET_FEATURES / SATA_DEVSLP prior to programming
the host controller? that order seems wrong.
Per our understanding, there is no sequence requirement on this,
please correct me if you see risk.
Thanks,
Shane