Thread (66 messages) 66 messages, 11 authors, 2010-09-18

Re: [PATCH 42/41 v2] dm: convey that all flushes are processed as empty

From: Tejun Heo <tj@kernel.org>
Date: 2010-09-08 16:09:43
Also in: dm-devel, linux-fsdevel, linux-raid, linux-scsi, lkml

On 09/08/2010 04:04 AM, Mike Snitzer wrote:
Rename __clone_and_map_flush to __clone_and_map_empty_flush for added
clarity.

Simplify logic associated with REQ_FLUSH conditionals.

Introduce a BUG_ON() and add a few more helpful comments to the code
so that it is clear that all flushes are empty.

Cleanup __split_and_process_bio() so that an empty flush isn't processed
by a 'sector_count' focused while loop.

Signed-off-by: Mike Snitzer <redacted>
---
 drivers/md/dm.c |   34 +++++++++++++++-------------------
 1 files changed, 15 insertions(+), 19 deletions(-)

Tejun, please feel free to fold this patch into (or insert after)
0025-dm-relax-ordering-of-bio-based-flush-implementation.patch
I added it after 26 and updated flush-fua branch accordingly.

Thank you.

-- 
tejun
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help