Re: [PATCH libata-dev-2.6:sil24 02/07] sil24: move error handling out of hot interrupt path
From: Jeff Garzik <hidden>
Date: 2005-08-11 19:18:10
From: Jeff Garzik <hidden>
Date: 2005-08-11 19:18:10
Tejun Heo wrote:
02_sil24_separate-out-error-path.patch Move error handling from sil24_host_intr into separate function - sil24_error_intr. Jeff, I don't think this patch actually improves readability and/or performance. Is this what you wanted?
Yes. It improves readability and maintainability by clearly separating the error and non-error paths. It improves performance by removing an uncommon path -- error -- from the hot path (command completion). Jeff