Thread (2 messages) 2 messages, 2 authors, 2004-08-23

Samba + SX4 + RAID5 + Ext3 = Aborted Journal

flat view

From: Ryan Bourgeois <hidden>
Date: 2004-08-23 04:16:31

As the subject states, I'm experiencing aborted journals on my RAID array after large writes or a large number of writes.  The strange thing is, it only seems to happen when doing these writes from another machine via Samba.  It doesn't happen via NFS.  And it only happens on the RAID array.  Here's my dmesg:

kjournald starting.  Commit interval 5 seconds
EXT3 FS on md0, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
kjournald starting.  Commit interval 5 seconds
EXT3 FS on md0, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
eth2: Setting full-duplex based on MII#1 link partner capability of 45e1.
eth1: Setting full-duplex based on MII#1 link partner capability of 45e1.
EXT3-fs error (device md0): ext3_new_block: Allocating block in system zone - block = 35454976
Aborting journal on device md0.
ext3_reserve_inode_write: aborting transaction: Journal has aborted in __ext3_journal_get_write_access<2>EXT3-fs error (device md0) in ext3_reserve_inode_write: Journal has aborted
ext3_getblk: aborting transaction: Journal has aborted in __ext3_journal_get_create_access<3>ext3_reserve_inode_write: aborting transaction: Journal has aborted in __ext3_journal_get_write_access<2>EXT3-fs error (device md0) in ext3_reserve_inode_write: Journal has aborted
ext3_abort called.
EXT3-fs abort (device md0): ext3_journal_start: Detected aborted journal
Remounting filesystem read-only
EXT3-fs error (device md0) in start_transaction: Journal has aborted
EXT3-fs error (device md0) in ext3_mkdir: Journal has aborted
__journal_remove_journal_head: freeing b_committed_data
__journal_remove_journal_head: freeing b_frozen_data
__journal_remove_journal_head: freeing b_frozen_data
__journal_remove_journal_head: freeing b_committed_data
__journal_remove_journal_head: freeing b_frozen_data
__journal_remove_journal_head: freeing b_frozen_data

I'm running the 2.6.8 kernel on both machines, but it's been happenning since I got the array set up, which was 2.6.3 I think, but I dunno...

I'm sure an alternative filesystem would work (I think) but that poses a data transfer problem of 120gbs...

-ryan
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help