On Wed, Apr 28, 2021 at 05:57:51PM +0300, Andy Shevchenko wrote:
One may notice that dev_printk(KERN_DEBUG ...) is *not* an equivalent
to dev_dbg(). It will be printed whenever loglevel is high enough.
And currently it will be the only message in the I²C core in some
configurations that got printed under above conditions.
Moving to dev_dbg() will hide it in the configurations where Dynamic Debug
is enabled and hence align with all other debug messages in the I²C core..
OK in general.
+ bool error_or_debug = true;
A bool having "or" in the name is quite confusing: "do you want this or
that" - "yes!" :) What about "is_error_level"?