Re: [PATCH v2 4/5] gpiolib: cdev: reduce locking in gpio_desc_to_lineinfo()
From: Andy Shevchenko <andy@kernel.org>
Date: 2023-12-14 15:50:27
Also in:
lkml
On Thu, Dec 14, 2023 at 11:34:44PM +0800, Kent Gibson wrote:
On Thu, Dec 14, 2023 at 05:27:29PM +0200, Andy Shevchenko wrote:quoted
On Thu, Dec 14, 2023 at 11:19:01PM +0800, Kent Gibson wrote:quoted
On Thu, Dec 14, 2023 at 05:10:23PM +0200, Andy Shevchenko wrote:quoted
On Thu, Dec 14, 2023 at 05:58:13PM +0800, Kent Gibson wrote:
...
quoted
quoted
quoted
quoted
- spin_lock_irqsave(&gpio_lock, flags);Shouldn't this be covered by patch 1 (I mean conversion to scoped_guard() instead of spinlock)?Read the cover letter. Doing that made the change larger, as flags gets removed then restored. I had also thought the flag tests would get indented then unindented, but if we use guard() the indentation should remain unchanged.I'm fine with that as I pointed out (have you received that mail? I had problems with my mail server) the dflags is better semantically, so restoration with _different_ name is fine.I have noted that some of your replies have been delayed, and I can't be sure of what I might not've received. I can't say I've seen one that mentions the dflags name being preferable. I prefer the plain flags name, if there is only one flag variable in the function.
I pointed out that lflags / dflags is kinda idiomatic internally to gpiolib* code base. Using flags might feel misleading and otherwise will hint about semantics of the variable. That said, I prefer it being named dflags. -- With Best Regards, Andy Shevchenko