Thread (13 messages) flat view 13 messages, 3 authors, 2021-11-22

Re: [PATCH v2 1/2] gpiolib: improve coding style for local variables

From: Johan Hovold <johan@kernel.org>
Date: 2021-11-19 07:57:20
Also in: lkml

On Thu, Nov 18, 2021 at 02:23:16PM +0100, Bartosz Golaszewski wrote:
quoted hunk ↗ jump to hunk
Drop unneeded whitespaces and put the variables of the same type
together for consistency with the rest of the code.

Signed-off-by: Bartosz Golaszewski <redacted>
Reviewed-by: Linus Walleij <redacted>
---
 drivers/gpio/gpiolib.c | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)
diff --git a/drivers/gpio/gpiolib.c b/drivers/gpio/gpiolib.c
index abfbf546d159..20d63028b85c 100644
--- a/drivers/gpio/gpiolib.c
+++ b/drivers/gpio/gpiolib.c
@@ -594,11 +594,10 @@ int gpiochip_add_data_with_key(struct gpio_chip *gc, void *data,
 			       struct lock_class_key *request_key)
 {
 	struct fwnode_handle *fwnode = gc->parent ? dev_fwnode(gc->parent) : NULL;
-	unsigned long	flags;
-	int		ret = 0;
-	unsigned	i;
-	int		base = gc->base;
+	int ret = 0, base = gc->base;
This only makes the code harder to read for no good reason.

Keep declarations on separate lines, especially if also initialising.

Note that all but one function in this file initialises return value
variables on their own lines too (as they should).
 	struct gpio_device *gdev;
+	unsigned long flags;
+	unsigned int i;
 
 	/*
 	 * First: allocate and populate the internal stat container, and
Johan
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help