Thread (46 messages) 46 messages, 4 authors, 2020-08-06

Re: [PATCH v2 02/18] gpio: uapi: define uAPI v2

From: Bartosz Golaszewski <hidden>
Date: 2020-08-06 17:27:00
Also in: lkml

On Thu, Aug 6, 2020 at 3:15 AM Kent Gibson [off-list ref] wrote:
On Wed, Aug 05, 2020 at 01:18:53PM +0800, Kent Gibson wrote:
quoted
On Tue, Aug 04, 2020 at 07:42:34PM +0200, Bartosz Golaszewski wrote:
quoted
On Sat, Jul 25, 2020 at 6:20 AM Kent Gibson [off-list ref] wrote:
[snip]
quoted
quoted
quoted
config, info, info_changed and event structs receive updated versions,
and the first three new ioctls.

Signed-off-by: Kent Gibson <warthog618@gmail.com>
---
Hi Kent,

Thanks a lot for your work on this. Please see comments below.

One thing I'd change globally for better readability is to have all
new symbols marked as v2 - even if they have no counterparts in v1. I
know libgpiod will wrap it all anyway but I think it's still a good
way to make our work in user-space easier.
Fair enough.  Oh joy.
Given that the intent is to highlight that the symbols are related to the
v2 of the GPIO uAPI, and not the second version of a particular type, it
makes more sense to me that the v2 is placed adjacent to the GPIO in the
name.  e.g. gpioline_flag_v2 would become gpiov2line_flag.

Does that work for you?
Yes, except that gpiov2line is a terrible prefix. Perhaps we should
make that into gpiov2_line_flag and same for all others? Maybe even
gpio_v2_line_flag if that doesn't make the symbols too long/too hard
to read.

Bartosz
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help