Thread (32 messages) 32 messages, 6 authors, 1d ago

Re: [PATCH v5 06/14] mfd: lm3533-core: Remove redundant pdata helpers

From: Johan Hovold <johan@kernel.org>
Date: 2026-07-03 09:57:20
Also in: dri-devel, linux-devicetree, linux-iio, linux-leds, lkml

On Wed, Jun 17, 2026 at 11:00:23AM +0300, Svyatoslav Ryhel wrote:
The lm3533_set_boost_freq() and lm3533_set_boost_ovp() functions are used
only in lm3533_device_setup(), which in turn is only called by
lm3533_device_init(). Incorporate their code directly into
lm3533_device_init() to simplify driver readability.
Again, this isn't needed. Why are you removing abstraction that improve
readability?

Johan
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help