On Tue, May 26, 2026 at 05:01:48PM +0200, Geert Uytterhoeven wrote:
Hi Uwe,
On Tue, 26 May 2026 at 16:17, Uwe Kleine-König (The Capable Hub)
[off-list ref] wrote:
quoted
this series is about improving the handling of pointers in struct
zorro_device_id's driver_data.
While it's ok on all current Linux platforms to store a pointer in an
unsigned long variable, it involves casting that loses type information.
This can be nicely seen in patch #7 where after profiting from patch #6
the compiler notices a missing const.
Preparing for that change, all zorro_device_ids are converted to use
named initializers, which is also a nice cleanup that could stand for
itself, as it improves readability for humans. (That is necessary
because an anonymous union can be initialized by name, but not using a
list initializer.)
My motivation for this series is the CHERI hardware extension. With that
pointers are bigger than longs and thus you cannot store pointers in
zorro_device_id::driver_data. So this series is also about getting
support for CHERI into the mainline, but I hope the clean up effects
mentioned above are justification enough to accept this series.
Thanks for your series!
quoted
The dependencies in this series are as follows:
- Patch #5 depends on #1, #2
s/5/6/?
quoted
- Patches #7 and #8 depend on patch #6.
So if the ata maintainers agreed to merge their patch #1 via scsi, and
Geert agrees to patch #5 and that it's also merged via scsi, patches #1,
s/5/6/?
Yes, indeed. And I tried so hard to get all the numbers right :-\
Best regards
Uwe