On Wed, Mar 04, 2026 at 12:24:28AM +0100, Gabriel Windlin wrote:
The CURRENT_GATE_VGA, CURRENT_GATE_PWM, CURRENT_GATE_SSP, and
CURRENT_GATE_ZVPORT bit field macros, the CRT_HWC hardware cursor
register macros, the DMA_1_SOURCE, DMA_1_DESTINATION, and
DMA_1_SIZE_CONTROL register macros, and the unused
DMA_ABORT_INTERRUPT_ABORT_0, DMA_ABORT_INTERRUPT_INT_1, and
DMA_ABORT_INTERRUPT_INT_0 bit field macros defined in ddk750_reg.h
are not referenced anywhere in the driver. Remove them to reduce dead
code as noted in the TODO file.
Signed-off-by: Gabriel Windlin <redacted>
---
drivers/staging/sm750fb/ddk750_reg.h | 41 ----------------------------
We always remove unused code, but I don't really understand the point
of removing these. It's not like they hurt readability. They function
as documentation.
regards,
dan carpenter