Thread (7 messages) 7 messages, 2 authors, 2025-06-19

Re: [PATCH v2] staging: sm750fb: rename 'proc_setBLANK'

From: Kisub Choe <hidden>
Date: 2025-06-19 13:49:30
Also in: linux-staging, lkml

On Thu, Jun 19, 2025 at 03:24:26PM +0200, Greg KH wrote:
On Thu, Jun 19, 2025 at 10:12:13PM +0900, Kisub Choe wrote:
quoted
On Wed, Jun 18, 2025 at 04:26:10PM +0200, Greg KH wrote:
quoted
On Wed, Jun 18, 2025 at 11:15:55PM +0900, Kisub Choe wrote:
quoted
Rename 'proc_setBLANK' to 'proc_setBLANK' to
That doesn't rename anything :(
Rename 'proc_setBLANK' to 'proc_set_blank' to
quoted

quoted
conform with kernel style guidelines as reported by checkpatch.pl

CHECK: Avoid CamelCase: <proc_setBLANK>

Signed-off-by: Kisub Choe <redacted>
---
 drivers/staging/sm750fb/sm750.c | 4 ++--
 drivers/staging/sm750fb/sm750.h | 2 +-
 2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/sm750fb/sm750.c b/drivers/staging/sm750fb/sm750.c
index 1d929aca399c..bb2ade6030c2 100644
--- a/drivers/staging/sm750fb/sm750.c
+++ b/drivers/staging/sm750fb/sm750.c
@@ -577,7 +577,7 @@ static int lynxfb_ops_blank(int blank, struct fb_info *info)
 	pr_debug("blank = %d.\n", blank);
 	par = info->par;
 	output = &par->output;
-	return output->proc_setBLANK(output, blank);
+	return output->proc_set_blank(output, blank);
 }
 
 static int sm750fb_set_drv(struct lynxfb_par *par)
@@ -605,7 +605,7 @@ static int sm750fb_set_drv(struct lynxfb_par *par)
 	crtc->ypanstep = 1;
 	crtc->ywrapstep = 0;
 
-	output->proc_setBLANK = (sm750_dev->revid == SM750LE_REVISION_ID) ?
+	output->proc_set_blank = (sm750_dev->revid == SM750LE_REVISION_ID) ?
 				 hw_sm750le_set_blank : hw_sm750_set_blank;
Why do we even need this function pointer?  Why not just do the check
above when it is called instead of this indirection?

thanks,

greg k-h
Dear Greg,

Here is the updated patch with revised commit message. No code changes.
Please read the documentation for how to send an updated patch (hint, it
needs to be a new version).

Also, see my comments above about what you should do here instead of
just renaming the variable.  Please make that change which will remove
the variable entirely.

thanks,

greg k-h
Thank you for feedback.

I was wondering if you could share additional feedback regarding
pros and cons calling a function directly based on the condition instead of the
current implementation?

Regards,
Kisub Choe.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help